Press Enter to search · ESC to close

Crypto

Critical Vulnerability in Alby Hub: Funds Could Be Stolen if API Is Publicly Exposed

Alby has confirmed that Alby Hub versions v1.7.0 through v1.18.5 contain a critical vulnerability. If the admin API is exposed to the public internet, an attacker could gain unauthorized access and move funds. There is one known affected user. Alby strongly urges users to restrict public access, update to v1.24.0, and change the unlock password. Versions v1.19.0 and later are not affected.

AI take

This is a reminder that self-custody software is only as secure as its deployment. The narrow condition—public API exposure—means the practical risk is concentrated among users who misconfigured their setup, yet the one confirmed case shows the stakes are real. For the broader Lightning ecosystem, it highlights how operational hygiene, not just code, determines fund safety. The open question is whether this incident prompts stricter default settings or clearer warnings in future releases, as the gap between affected and safe versions suggests the fix was already in circulation.

Generated by AI for reference only.

Share

Related News

TREE NEWS share card
Long-press image above → Save to Photos / Share
Pitch us Feedback